AI Not building, sleeping or generally misbehaving?

Report bugs here! Please use the template when posting. For help running the game, please use the tech support forum.
Posts: 4
Joined: Mon Nov 10, 2014 2:56 pm

Re: AI Not building, sleeping or generally misbehaving?

Post by FantasticTuesday » Mon Nov 10, 2014 3:21 pm

I encountered two problems causing AI to break.

I'll start with toilets since I'm reasonably sure you know about this, what with them not being fully implemented.

Here's an album cataloging the problem.


It occured after a save/load cycle so that might have something to do with it. Basically the toilet could not be cancelled like other objects, and seemed to behave as a plant. Chortle. When built, it still had the green outline, and forced the colonists into an endless loop of attempting to build an object that was already there.

The second, perhaps more critical, problem is that save/load cycles that don't include restarting the game cause colonists and the IMP to ignore every object built or ordered before the save was made. After the load, they all stood around doing nothing at all, not repairing anything, not building anything, and I even got an email asking me for a workshop table despite there being two that had previously been used without issue. When I ordered a new table, they went around building that and any objects ordered afterwards. The IMP ignored previously given dig commands until I cancelled and re-gave them. Critically, they would not interact with anything that hadn't been placed after the save.

Posts: 3
Joined: Sun Aug 31, 2014 9:20 pm

Re: AI Not building, sleeping or generally misbehaving?

Post by nightarix » Wed Nov 19, 2014 2:43 pm

IMP got stuck and wasn't moving on my last run, I haven't tested for the cause of it but i think its one of the following, (can't try reloading it as i realized i forgot to save after i closed the game >.<) anyways i noticed the imp was standing almost still in place(he was sort of jittering back and forth as though he was trying to move but wouldn't), and had several tasks listed.
the possible causes i believe are
1) the tutorial broke it? (i ran it to check if anything new was added to it)
2) i made and subsequently canceled some mining tasks.(possibly the IMP hadn't removed the tasks and the game ended up confused?)
3) i had immediately changed the "spawn" room into a workshop upon closing the tutorials opening message.(not sure if this caused it since the colonists had shortly after my completion of the tutorial and got food and water for themselves)
another possibility is i had simply stumbled upon a pause button(i don't know if one even exists... the read-me doesn't list one anyways) and simply didn't realize it.

Posts: 16
Joined: Sun Dec 22, 2013 1:02 am

Re: AI Not building, sleeping or generally misbehaving?

Post by feneris » Thu Dec 04, 2014 8:09 am

Operating on Version 0.46

So I have this problem where after a certain length of time my colonists seem to get stuck in a loop, and will basically alternate from sleeping and eating, getting nothing done. The IMPs still work fine, however.

Now I don't know if this is a bug or merely one of myriad of gameplay elements that have not been explained.

Posts: 3
Joined: Wed Mar 18, 2015 1:35 pm

Re: AI Not building, sleeping or generally misbehaving?

Post by deltadeath93 » Thu Mar 19, 2015 12:54 am

version 48 i have had 3 colonists die of starvation and 2 die from exhaustion and one die from asfixiation in a spacesuit outside
starvation whilei have a full 8 block livestock room with chickens and a 12 block hydro room full of fruit plants i also havea living quarters room with 12 beds and 2 toilets in it.

i spawned 3 bots i have 1 working when i cal lofr it one the walked thru the cave walls to the oposite side of map and refuses to move and one stuck ina loop changing out water barrels from my 6 solar water stations

Posts: 1
Joined: Sat Nov 24, 2018 8:10 pm

Re: AI Not building, sleeping or generally misbehaving?

Post by Meia » Sat Nov 24, 2018 8:28 pm

I also experiencing those kind of bugs.

Mine is with pathing problems and airlock. At a point my colonist will never go outside. Robots, imp and repair, have no trouble getting outside the airlock and such. My colony was doing good. All heat, temp, air, light, food, health was fine.

Problems is when i try to build like wind turbine or a turret or w/e outside. I got a pathing error that they can't find a way to the table and ressource when inside the base everything works fine. I tried to add an airlock to bypass this bug but nothing worked. Airlock can't get constructed where ever i place it even behind a bulk head doors that lead to an open cave to the outside.

There is also some object in the same game that doesn't seem to be built. The intravenous pole thing of med room and a tight/wide pole light in my living room. THIS TIME no pathing error they just don't build it.

I got plenty, plenty of raw materials and also alot of refined one. i still have space in my storage room. Also i realised that all my colonist carying alot of stuff on them like raw materials and refined one when they have space to drop it off.

well my game got locked in some way since i can't build outside. I've found a thermal vent so i tried to build a geo electricity thing and never got build.

Always in the same game, there 2-3 things that got displaced. First is the air-out vent on a wall while i was placing a room next to another one, the vent got teleported right into a doors. so i deleted it. Second things is the Screen. after a quick save and reload (attempting to solve the airlock issue), my screen got teleported behind a wall. I enlarged the room to build a room back of the wall so the screen can get back in but it got pushed again behind the new wall. It was in a storage room.

one of my colonist got stuck after building a inertial wheel thingy wich i had to delete because colonist would have died.

The colonist message to clear veggies at the airlock entrance never assigned my imp to do it even if they were marked i had to manualy control the bot to make it happen.

Well i hope this can help you out i really want to enjoy this game but can't seem to get far. This is my 5th try out but i never get far due to bug and such problems.


Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest