IMPs try to reuse fossile stands that are full [0.54]

Report bugs here! Please use the template when posting. For help running the game, please use the tech support forum.
Post Reply
Woetoo
Posts: 70
Joined: Wed Jun 24, 2015 10:40 am

IMPs try to reuse fossile stands that are full [0.54]

Post by Woetoo » Thu Mar 31, 2016 8:04 pm

Alpha build number: 0.54
Operating System: Windows 7

Bug severity: Unexpected behaviour - IMPs try to reuse full fossil stands

I tend to build multiple fossil stands in my research room. One bug I got multiple times today were IMPs bringing fossils to fossil stands that were already in use.
The IMP would do the animation of placing the fossil on the stand, but the fossil would remain at the IMP's feet and the IMP would refuse to move again.
It only seemed to do it when other fossil stand templates had been placed, but the stand itself hadn't yet been built. (e.g. 3 stands have been built and are already in use, 5 other stands are still waiting to be constructed).

Save+Load clears the problem, or at least makes it go away in one form or another.

Sometimes, the IMP would return to the same full stand and try again.
Sometimes the existing fossil on the stand would disappear, sometimes not. Sadly it was pretty inconsistent.

User avatar
SimoRoth
Site Admin
Posts: 1106
Joined: Sat Jul 14, 2012 11:28 am

Re: IMPs try to reuse fossile stands that are full [0.54]

Post by SimoRoth » Mon Apr 04, 2016 3:33 pm

Yeah saw this on the stream and have replicated. Will look at fixing for 0.55 or 0.56 depending on complexity.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 1 guest