Windows Engine Test (Complete)

Discussion of Maia's on going development, including modding.
User avatar
StfN
Posts: 85
Joined: Wed Jan 23, 2013 7:33 pm
Location: Vienna, Austria
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Windows Engine Test

Post by StfN » Thu Apr 04, 2013 9:26 pm

SimoRoth wrote:
StfN wrote:The new .exe seems to be worse for me than the last one. This one crashes on moving around with WASD even on the 1600x900 resolution. Nothing else seems to have changed (as in, still crashes on pretty much anything I do)
Odd. Could you try turning off all the application preferences in the NV control panel. I think it might be fighting my settings.
Turned everything I could to "application controlled": Game crashes after a few seconds even without input (past the click on the start-screen)
Turned everything I could to "off": Game crashes instantly, won't even show start-screen.
After some playing around I found that "Thread Optimization" needed to be something other than "Off". So with that on "Auto", and everything else on "Off", the game seems to be running the way it with the first exe. Usualy crashes as soon as I move around a bit or rotate the camera, can't place any objects. New world generation works well now though. Every once in a while a get a run where I can move for a long while without it crashing. On those it dies as soon as I click on rocks.
The above applies for 1920x1080. It does not crash on 1600x900 on moving around with the above settings.
Windows 7 64-bit
Intel Core i7 4770K (4.0 GHz)
16 GB RAM
NVIDIA GeForce GTX 770, 4GB

User avatar
SimoRoth
Site Admin
Posts: 1106
Joined: Sat Jul 14, 2012 11:28 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Windows Engine Test

Post by SimoRoth » Thu Apr 04, 2013 9:29 pm

StfN wrote:
SimoRoth wrote:
StfN wrote:The new .exe seems to be worse for me than the last one. This one crashes on moving around with WASD even on the 1600x900 resolution. Nothing else seems to have changed (as in, still crashes on pretty much anything I do)
Odd. Could you try turning off all the application preferences in the NV control panel. I think it might be fighting my settings.
Turned everything I could to "application controlled": Game crashes after a few seconds even without input (past the click on the start-screen)
Turned everything I could to "off": Game crashes instantly, won't even show start-screen.
After some playing around I found that "Thread Optimization" needed to be something other than "Off". So with that on "Auto", and everything else on "Off", the game seems to be running the way it with the first exe. Usualy crashes as soon as I move around a bit or rotate the camera, can't place any objects. New world generation works well now though. Every once in a while a get a run where I can move for a long while without it crashing. On those it dies as soon as I click on rocks.
The above applies for 1920x1080. It does not crash on 1600x900 on moving around with the above settings.
Great thanks. That's given me some clues as to the issues.

User avatar
Tikigod
Posts: 152
Joined: Thu Apr 04, 2013 9:29 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Windows Engine Test

Post by Tikigod » Thu Apr 04, 2013 9:41 pm

SimoRoth wrote:Just posted a new exe.

ATI users does it work!?

Also fixed - Evil blue fog.
You can zoom out 3x as far now.
Pressing L now deletes previous world's objects and plants. (still leaks some memory, but its only a debug tool!)
Sound disabled. (Its been the root of a few crashes)
Crashes on my system.

Windows problem report:
Spoiler: show
Problem signature:
Problem Event Name: APPCRASH
Application Name: Maia.exe
Application Version: 0.0.0.0
Application Timestamp: 515de434
Fault Module Name: aticfx32.dll
Fault Module Version: 8.17.10.1191
Fault Module Timestamp: 5147cb54
Exception Code: c00000fd
Exception Offset: 0003709c
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Information 1: 3810
Additional Information 2: 38107a394caf6c6d0ba823695c961da3
Additional Information 3: 214f
Additional Information 4: 214f7b0cd681de43ecc191710b555b9c
Attempting to run both with fullscreen enabled and disabled, at 1600x900 (desktop native resolution).

No extra information from running through terminal, just the same almost instant windows error that Maia.exe has stopped responding.

dxdiag report

Using AMD Catalyst 13.3 Beta3 drivers in that report, but same problem when using stable release drivers as well.


Simon, is there meant to be any kind of output log file being created that reports step-by-step the processes being attempted for when problems do occur such as near instant crashes when firing up? As can't seem to find one anywhere which seemed a bit unusual for a engine test build.
Last edited by Tikigod on Thu Apr 04, 2013 9:46 pm, edited 3 times in total.
Violence is the last refuge of the incompetent - Isaac Asimov

My channel. Game recordings & old 3D art assets I've made.

fohx
Posts: 7
Joined: Thu Apr 04, 2013 6:11 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Windows Engine Test

Post by fohx » Thu Apr 04, 2013 9:42 pm

Btw, last ninja debugging skills for today: Last GL-related function call I see here before the crash is wglChoosePixelFormat called by SDL_CreateWindow.

User avatar
SimoRoth
Site Admin
Posts: 1106
Joined: Sat Jul 14, 2012 11:28 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Windows Engine Test

Post by SimoRoth » Thu Apr 04, 2013 9:46 pm

New .exe is up. Should give more info in the terminal if it fails to run the graphics driver!
fohx wrote:Btw, last ninja debugging skills for today: Last GL-related function call I see here before the crash is wglChoosePixelFormat called by SDL_CreateWindow.
I was just looking at that code. May* have fixed it.

User avatar
Meneth
Posts: 25
Joined: Tue Oct 02, 2012 6:32 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Windows Engine Test

Post by Meneth » Thu Apr 04, 2013 9:49 pm

Another .exe, another crash:

Code: Select all

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	Maia.exe
  Application Version:	0.0.0.0
  Application Timestamp:	515df3ce
  Fault Module Name:	aticfx32.dll
  Fault Module Version:	8.17.10.1172
  Fault Module Timestamp:	50d21f11
  Exception Code:	c00000fd
  Exception Offset:	00037ca6
  OS Version:	6.1.7601.2.1.0.256.48
  Locale ID:	1044
  Additional Information 1:	e772
  Additional Information 2:	e77271159bd7df4c3732a2ba5858ede8
  Additional Information 3:	c2a7
  Additional Information 4:	c2a73a879b2977ff117116f713b1c55d

User avatar
StfN
Posts: 85
Joined: Wed Jan 23, 2013 7:33 pm
Location: Vienna, Austria
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Windows Engine Test

Post by StfN » Thu Apr 04, 2013 9:52 pm

Hmm, same as before for me. No additional output in the console either.
Windows 7 64-bit
Intel Core i7 4770K (4.0 GHz)
16 GB RAM
NVIDIA GeForce GTX 770, 4GB

User avatar
Tikigod
Posts: 152
Joined: Thu Apr 04, 2013 9:29 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Windows Engine Test

Post by Tikigod » Thu Apr 04, 2013 10:00 pm

Ok, managed to get it to at least run using my ATI graphics card, so actually got some output for what is trying to be loaded (When just running the .exe both via explorer and terminal there is simply no output what so ever, as windows halts the process before anything can happen.

Opened the new .exe to visual studio express as a new project then ran via debugging:

Output from maia.exe terminal window:
Spoiler: show
No game pad found.
Problem with joystick/gamepad.
Resources//Shaders//Shaders.xml
Resources//Shaders//Shaders.xml
Loading shader ScreenSpaceOcclusion
Loading shader bilateralBlurHorz
Loading shader bilateralBlurVert
Loading shader Simple
Loading shader Text
Loading shader GBuffer_Floor
Loading shader GBuffer_FloorBlended
Loading shader GBufferNM
Loading shader GBufferNM_ALPHA
Loading shader GBufferInstanced
Loading shader GBuffer
Loading shader GBufferAnimateUVs
Loading shader ScanlinesGui
Loading shader ShadowMap
Loading shader ShadowMapInstanced
Loading shader ShadowMapAlphaSway
Loading shader GBufferAlphaSway
Loading shader GBufferAlpha
Loading shader VirtualEntity
Loading shader VirtualEntityFail
Loading shader DiggingMarker
Loading shader RoomMarker
Loading shader Lava
Loading shader Lightpass
Loading shader PreBloom
Loading shader HorzBlur
Loading shader VertBlur
Loading shader FinalComp
Loading shader 3dGui
Loading shader Clouds
Loading shader Atmosphere
Loading shader AlphaParticle
Loading shader LavaParticle
Resources//Materials.xml
Resources//Engine/PipelineMaterials.xml
No such uniform named depthBuffer in shader FinalComp
No such uniform named impVis in shader FinalComp
No such uniform named blank in shader FinalComp
Resources//Engine/Fonts/FontMaterials.xml
Resources//Entities/EntityMaterials.xml
No such uniform named specular in shader GBuffer_Floor
No such uniform named random in shader ShadowMapAlphaSway
No such uniform named random in shader ShadowMapAlphaSway
No such uniform named Time in shader ScanlinesGui
No such uniform named normal in shader GBufferAnimateUVs
No such uniform named specular in shader GBufferAnimateUVs
Resources//Gui/GuiMaterials.xml
Resources//Particles/ParticleMaterials.xml
Resources//Assets.xml
Loading model failed:SpaceSuit
Loading model:Resources/Entities/Imp/Imp.modelSeq
Loading model:Resources/Entities/Chicken/Chicken.modelSeq
No such uniform named lightAttenuationBuffer in shader Lightpass
Resources//Engine//Fonts//Gui.fnt
Resources//Engine//Fonts//Gui.fnt
Visual Studio output debugging:
Spoiler: show
'Maia.exe' (Win32): Loaded 'C:\Users\Mike\Downloads\Maia\Maia_Windows_EngineStressTest_01\Maia.exe'. Module was built without symbols.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ntdll.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Program Files\AVAST Software\Avast\snxhk.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\kernel32.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\KernelBase.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Users\Mike\Downloads\Maia\Maia_Windows_EngineStressTest_01\SDL2.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\winmm.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msvcrt.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\user32.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\gdi32.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\lpk.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\usp10.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\advapi32.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\sechost.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\rpcrt4.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\sspicli.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\cryptbase.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\imm32.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msctf.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\oleaut32.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ole32.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\version.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\shell32.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\shlwapi.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Users\Mike\Downloads\Maia\Maia_Windows_EngineStressTest_01\glew32.dll'. Module was built without symbols.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\opengl32.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\glu32.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ddraw.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\dciman32.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\setupapi.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\cfgmgr32.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\devobj.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\dwmapi.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msvcp100.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msvcr100.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\apphelp.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Unloaded 'C:\Windows\SysWOW64\apphelp.dll'
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\uxtheme.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\atiglpxx.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\atioglxx.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\atiadlxy.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\propsys.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\userenv.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\profapi.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\wtsapi32.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\psapi.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ws2_32.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\nsi.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\IPHLPAPI.DLL'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\winnsi.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\wintrust.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\crypt32.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msasn1.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\atigktxx.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\aticfx32.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Unloaded 'C:\Windows\SysWOW64\atigktxx.dll'
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\atigktxx.dll'. Cannot find or open the PDB file.
>> First-chance exception at 0x00DA709C (aticfx32.dll) in Maia.exe: 0xC00000FD: Stack overflow (parameters: 0x00000001, 0x00362E30). << This is where windows normally freezes maia.exe and insists you close Maia
Unhandled exception at 0x00DA709C (aticfx32.dll) in Maia.exe: 0xC00000FD: Stack overflow (parameters: 0x00000001, 0x00362E30).
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\clbcatq.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msctf.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Unloaded 'C:\Windows\SysWOW64\msctf.dll'
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ole32.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Unloaded 'C:\Windows\SysWOW64\ole32.dll'
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msctf.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Unloaded 'C:\Windows\SysWOW64\msctf.dll'
'Maia.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msctf.dll'. Cannot find or open the PDB file.
'Maia.exe' (Win32): Unloaded 'C:\Windows\SysWOW64\msctf.dll'
The stackoverflow exception causes a break, but continuing via visual studio loads will allow maia to load.

Managed to get to the screen with the world, and also to the test environment itself with 2 imps and a cavern.

Will edit in more when encountered.

See this post for dxdiag report.


Performance on machine using Radeon HD 5770, I7 860 2.8GHZ machine:

Figures are given in stable ranges.

Cavern idle - 50-60FPS.
Cavern placing buildings - 40-60FPS
Moving camera from exterior to Cavern - 20-50FPS (Slight jutter sometimes)
Exterior (night) - 50-60FPS
Exterior (day) - 40-60FPS
Exterior placing buildings - 40-50FPS


Visual problems:

During the night, the fog/cloud effects around the exterior often make it impossible to see anything at all, during the day it's not really a problem.
Slight tiling problems with room tiles (Example: http://content.screencast.com/users/Tik ... oblems.png)
Last edited by Tikigod on Thu Apr 04, 2013 10:22 pm, edited 2 times in total.
Violence is the last refuge of the incompetent - Isaac Asimov

My channel. Game recordings & old 3D art assets I've made.

User avatar
SimoRoth
Site Admin
Posts: 1106
Joined: Sat Jul 14, 2012 11:28 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Windows Engine Test

Post by SimoRoth » Thu Apr 04, 2013 10:05 pm

New exe uploaded.

This one absolutely can not fail to print something to the terminal. :p

User avatar
Tikigod
Posts: 152
Joined: Thu Apr 04, 2013 9:29 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Windows Engine Test

Post by Tikigod » Thu Apr 04, 2013 10:20 pm

SimoRoth wrote:New exe uploaded.

This one absolutely can not fail to print something to the terminal. :p
Running just the .exe by itself now gives:

Game Started
Loading Config settings


Then windows halts the process and insists you kill it.

Running through visual studio debugging gives you the same output via the maia.exe terminal window and then as noted in my last post:

"Unhandled exception at 0x00C5CCBF (aticfx32.dll) in Maia.exe: 0xC00000FD: Stack overflow (parameters: 0x00000001, 0x002B2FFC)." and the option to break or continue.

On continuing the build runs no problems, and terminal output as aforementioned
Last edited by Tikigod on Thu Apr 04, 2013 10:23 pm, edited 1 time in total.
Violence is the last refuge of the incompetent - Isaac Asimov

My channel. Game recordings & old 3D art assets I've made.

Post Reply
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Who is online

Users browsing this forum: No registered users and 1 guest