Maia Backer Alpha 0.27 release notes.

Discussion of Maia's on going development, including modding.
User avatar
SimoRoth
Site Admin
Posts: 1104
Joined: Sat Jul 14, 2012 11:28 am

Maia Backer Alpha 0.27 release notes.

Post by SimoRoth » Fri Jun 14, 2013 1:20 am

A test build for you to check out the engine and have a play with some of the functions.

Log into your account on http://members.maiagame.com to download the latest zip.

Colonist/Creature AI is currently partly disabled. They wont build anything, eat or die... (yet)

wsad = movement.
mousewheel = zoom
alt + mouse mouse = rotate camera

Debug Controls:

j = Place rooms.
Press 1-5 for different room types.

h = Info mode. Click-place digging markers (on rock) / read info tips (on mouseover of objects)

k = Debug click-place objects (use v-b to scroll all objects ctrl for snap-to-grid )

u = Debug instabuild objects (gets rid of green hologram effect) .

Click to track any object in game.

l = regenerate world. (bugged: does not eradicate old rooms)

Escape = Exit

-/+ Keypad = Modify game time speed. (This will not be in final game, so don't report bugs!)

Please post your system specs along with any problems you have.

You will also need the VS Microsoft Visual C++ 2010 Redistributable Package: http://www.microsoft.com/en-in/download ... px?id=5555

You can edit the config.xml to change resolution and enable fullscreen.

Known bugs:

Black Screen - A lot of people will still get the black screen bugs with this build. I haven't had the time to port the shaders yet.

Attached is a small patch for the exe.
Attachments
Maia.zip
(174.95 KiB) Downloaded 287 times

Youjellyman
Posts: 15
Joined: Thu Apr 04, 2013 6:09 pm

Re: Maia Backer Alpha 0.27 release notes.

Post by Youjellyman » Fri Jun 14, 2013 2:10 am

I am getting a "pixel shader compilation failed" error.

User avatar
SimoRoth
Site Admin
Posts: 1104
Joined: Sat Jul 14, 2012 11:28 am

Re: Maia Backer Alpha 0.27 release notes.

Post by SimoRoth » Fri Jun 14, 2013 2:15 am

Yeah sorry I missed a file from the upload. New one uploading now. Will be 30 mins.

Youjellyman
Posts: 15
Joined: Thu Apr 04, 2013 6:09 pm

Re: Maia Backer Alpha 0.27 release notes.

Post by Youjellyman » Fri Jun 14, 2013 2:17 am

SimoRoth wrote:Yeah sorry I missed a file from the upload. New one uploading now. Will be 30 mins.
Thanks.

User avatar
SimoRoth
Site Admin
Posts: 1104
Joined: Sat Jul 14, 2012 11:28 am

Re: Maia Backer Alpha 0.27 release notes.

Post by SimoRoth » Fri Jun 14, 2013 2:20 am

If you cant wait... just go into resources/shaders/ and add the file I have attached (replacing anything that was there)

(removed, file now up to date)

User avatar
Tikigod
Posts: 152
Joined: Thu Apr 04, 2013 9:29 pm

Re: Maia Backer Alpha 0.27 release notes.

Post by Tikigod » Fri Jun 14, 2013 2:40 am

Seems to be a persistent CTD coming from somewhere, but the output log doesn't throw up any specific errors.

3 times now I've had CTDs whilst looking around, during which a few colonists are running around and the I.M.P robot has several dig orders lined up. Each time the output logs final output is a very small number such as:
Spoiler: show
Image

Windows rather unhelpful crash report mentions that the 'problem module' is "Fault Module Name: atioglxx.dll"

So may be a new ATI driver issue, the actual driver version I'm using is 12.104 atm and noticed there are newer beta drivers released this month so will try them and see if the problem persists.


Edit: Forgot to link to DXDIAG, silly me.

That should be pretty up to date and reflective of the driver version and such at the time the CTDs were occurring... except the driver version may be one update off as I was using the may released beta ones.


Edit 2:

Don't touch the Catalyst version 13.6 beta drivers from June!!!!

They currently bring back the ATI black screen problem when trying to run Maia, and when removing them they caused a BSOD partially through the process and buggered up my OS install so had to do a rollback to pre-13.6. Do not touch!

Catalyst 13.4 non-beta release from 29th May seem OK so far though.
Violence is the last refuge of the incompetent - Isaac Asimov

My channel. Game recordings & old 3D art assets I've made.

strolva
Posts: 2
Joined: Fri Jun 14, 2013 3:53 am

Re: Maia Backer Alpha 0.27 release notes.

Post by strolva » Fri Jun 14, 2013 4:10 am

Getting black screen as expected, updated graphics drivers and have latest version of the MS package.

DxDiag https://docs.google.com/document/d/1MDM ... sp=sharing

User avatar
Tikigod
Posts: 152
Joined: Thu Apr 04, 2013 9:29 pm

Re: Maia Backer Alpha 0.27 release notes.

Post by Tikigod » Fri Jun 14, 2013 4:43 am

strolva wrote:Getting black screen as expected, updated graphics drivers and have latest version of the MS package.

DxDiag https://docs.google.com/document/d/1MDM ... sp=sharing
You sure you're definitely using the latest release drivers there? Whilst it could just be different driver versions for differing hardware (btw, what card do you actually have in your machine?)....

Your dxdiag is showing:
Card name: AMD Radeon HD 6500M/5600/5700 Series
<snip>
Driver File Version: 8.17.0010.1191 (English)
Driver Version: 12.102.3.0 <<
DDI Version: 11
Driver Model: WDDM 1.1
Driver Attributes: Final Retail
Driver Date/Size: 4/16/2013 15:53:56, 1154240 bytes
WHQL Logo'd: n/a
Using the latest Catalyst 13.4 release, my DXdiag reports:
Card name: ATI Radeon HD 5700 Series
<snip>
Driver File Version: 8.17.0010.1191 (English)
Driver Version: 12.104.0.0 <<
DDI Version: 11
Driver Model: WDDM 1.1
Driver Attributes: Final Retail
Driver Date/Size: 3/29/2013 03:37:02, 1155264 bytes
WHQL Logo'd: Yes

Which is a bit of a driver version discrepancy IMO.
Violence is the last refuge of the incompetent - Isaac Asimov

My channel. Game recordings & old 3D art assets I've made.

strolva
Posts: 2
Joined: Fri Jun 14, 2013 3:53 am

Re: Maia Backer Alpha 0.27 release notes.

Post by strolva » Fri Jun 14, 2013 7:34 am

It's the mobile 5600m, works fine on my desktop which has and AMD 7800, not sure if I have latest drivers.

Desktop DxDiag https://docs.google.com/document/d/1YkQ ... sp=sharing

cryptoshrimp
Posts: 6
Joined: Wed May 15, 2013 7:03 pm

Re: Maia Backer Alpha 0.27 release notes.

Post by cryptoshrimp » Fri Jun 14, 2013 10:48 am

I played with this version a bit, and only have a few things I noticed.

- For me, it takes a really long time to start up. The game will stay white for at least a minute, but then eventually run. In the error log, there are a lot of "no such uniform called X in shader Y".
- All the colonists are called S. Anderson.
- In three of the four test games I played, the IMP bot was completely paralysed by confusion if given more than one available dig order at a time.
- I've managed to crash the game twice by rotating and then scrolling, but haven't been able to reproduce this a third time, so it might have just been an accident.
- the weird black blocks on the side of the screen are still there.

I think you've implemented some sort of context sensitivity with item placements? You can't select wind farms and such inside, and the workshop can't have an IV drip, stuff like that. It's very buggy. If you move the cursor a lot it jumps back to doors, sometimes cycling through the item list doesn't have any effect.

- cycling through items quickly produces massive lag if the fps meter is accurate, since it drops from ~35 to ~7 if I press them really quickly.
- Also your chair model seems to be bugged.

I'll play around a bit more and see what else I can find. Hope it's useful.

Locked

Who is online

Users browsing this forum: No registered users and 1 guest