Alpha 0.40.1 Hotfix Patch Notes

Discussion of Maia's on going development, including modding.
Post Reply
User avatar
SimoRoth
Site Admin
Posts: 1103
Joined: Sat Jul 14, 2012 11:28 am

Alpha 0.40.1 Hotfix Patch Notes

Post by SimoRoth » Wed Mar 05, 2014 8:57 pm

Sorry for the delay. Bad weather in the UK meant I lost a week due to be trapped by the flooding, and I lost another hunting down the Intel 3000HD bug. Intel now have the bug so hopefully they can release a fix or help me workaround it.

Build is now up on Steam for Windows users.

Changes:
  • Fixes for XP support.
  • Large address aware memory fixes.
  • Fixes to reduce GPU memory fragmentation (performance win)
  • Shader tweaks for better performance.
  • Microwave communications tower added.
  • Door locking and unlocking added. (click on doors)
  • Turning objects on and off. (click on lights, atmosphere gens etc)
  • A multitude of gameplay related crash fixes.
  • Fixed GUI crash when placing things on the edge of the world.
  • Lots of new Infotip text and corrections.
  • New animations and rig for the space suit.
  • Save game optimisation and crash fixes.
Some save games may break.

Alryn
Posts: 8
Joined: Wed Feb 19, 2014 5:26 pm

Re: Alpha 0.40.1 Hotfix Patch Notes

Post by Alryn » Wed Mar 05, 2014 9:27 pm

There was a new driver update from Intel the other day, which I have installed myself, hopefully that was the fix from them.

I understand the flooding problem I'm close to the source of the severn here, but we've been lucky here thankfully.

User avatar
SimoRoth
Site Admin
Posts: 1103
Joined: Sat Jul 14, 2012 11:28 am

Re: Alpha 0.40.1 Hotfix Patch Notes

Post by SimoRoth » Wed Mar 05, 2014 9:54 pm

Hah yeah. I posted the first time it happened: download/file.php?id=180&mode=view

Thankfully the this time they decided to get some huge pumps and drain the street.

Carch
Posts: 9
Joined: Tue Dec 17, 2013 10:53 am

Re: Alpha 0.40.1 Hotfix Patch Notes

Post by Carch » Thu Mar 06, 2014 2:18 pm

those pumps came from over here! glad we could help.

now.. when I start the hotfixed version (did a clean download); it does.. completely nothing. the proces just sits there using 340 kb of RAM. at least the .40 version crashed. and the .39 version not on steam even told me it was missing something :D

dx diag file:

https://www.dropbox.com/s/tx3g7mkq3jr3sio/DxDiag.txt

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest